Website Down
Incident Report for The Plug
Resolved
We're back online and all service should be functioning as expected. Thanks for hanging with us!
Posted Dec 09, 2019 - 00:51 UTC
Investigating
Sorry for the disruption! The Plug website is currently down. Our engineers are investing and we hope to have an update soon!
Posted Dec 09, 2019 - 00:47 UTC
This incident affected: Web Host.